using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$";
string input = @"name@domain.com
name@
namedomain.com
domain.com
firstname.lastname@domain.com
name@subdomain.domain.com
firstname+lastname@example.com
firstname_lastname@domain.com
firstname-lastname_test@domain.com
firstname$$@domain.com
// You can see the original post at albertcolom.com/blog";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}