use strict;
my $str = 'name@domain.com
name@
namedomain.com
domain.com
firstname.lastname@domain.com
name@subdomain.domain.com
firstname+lastname@example.com
firstname_lastname@domain.com
firstname-lastname_test@domain.com
firstname$$@domain.com
// You can see the original post at albertcolom.com/blog';
my $regex = qr/^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}