import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,6})*$";
final String string = "name@domain.com\n"
+ "name@\n"
+ "namedomain.com\n"
+ "domain.com\n"
+ "firstname.lastname@domain.com\n"
+ "name@subdomain.domain.com\n"
+ "firstname+lastname@example.com \n"
+ "firstname_lastname@domain.com\n"
+ "firstname-lastname_test@domain.com\n"
+ "firstname$$@domain.com\n\n"
+ "// You can see the original post at albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}