const regex = /^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,6})*$', 'gm')
const str = `name@domain.com
name@
namedomain.com
domain.com
firstname.lastname@domain.com
name@subdomain.domain.com
firstname+lastname@example.com
firstname_lastname@domain.com
firstname-lastname_test@domain.com
firstname\$\$@domain.com
// You can see the original post at albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}