#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(?i)\b0+([0-9a-f]{1,4})\b|(?:\b|:)((?:0(?::0)+))(?=(:|$))"
Local $sString = "2001:0db8:abcd:0012:0000:0000:0000:0001" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00a2" & @CRLF & _
"2001:0db8:abcd:0012:0000:0000:0000:00ff"
Local $sSubst = "$1$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)