using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b0+([0-9a-f]{1,4})\b|(?:\b|:)((?:0(?::0)+))(?=(:|$))";
string substitution = @"$1$2$3";
string input = @"2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}