use strict;
my $str = '2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff';
my $regex = qr/(?i)\b0+([0-9a-f]{1,4})\b|(?:\b|:)((?:0(?::0)+))(?=(:|$))/ip;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";