const regex = /(?i)\b0+([0-9a-f]{1,4})\b|(?:\b|:)((?:0(?::0)+))(?=(:|$))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b0+([0-9a-f]{1,4})\\b|(?:\\b|:)((?:0(?::0)+))(?=(:|$))', 'gi')
const str = `2001:0db8:abcd:0012:0000:0000:0000:0001
2001:0db8:abcd:0012:0000:0000:0000:00a2
2001:0db8:abcd:0012:0000:0000:0000:00ff`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);