using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"A(?:(?![A-Z]{2}).)*?(\d+)";
string input = @"A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd
A BCd 1
A bcd 1 EF
must start with an A
followed by any count of anything unless it's two consecutive upper case letter
followed by a number (which should be captured)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}