const regex = /A(?:(?![A-Z]{2}).)*?(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A(?:(?![A-Z]{2}).)*?(\\d+)', 'gm')
const str = `A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd
A BCd 1
A bcd 1 EF
must start with an A
followed by any count of anything unless it's two consecutive upper case letter
followed by a number (which should be captured)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}