import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "A(?:(?![A-Z]{2}).)*?(\\d+)";
final String string = "A bcd 1 should match and capture 1\n"
+ "Abcd1 should match and capture 1\n\n"
+ "A bcd\n"
+ "A BCd 1\n"
+ "A bcd 1 EF\n\n"
+ "must start with an A\n"
+ "followed by any count of anything unless it's two consecutive upper case letter\n"
+ "followed by a number (which should be captured)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}