import Foundation
let pattern = #"A(?:(?![A-Z]{2}).)*?(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A bcd 1 should match and capture 1
Abcd1 should match and capture 1
A bcd
A BCd 1
A bcd 1 EF
must start with an A
followed by any count of anything unless it's two consecutive upper case letter
followed by a number (which should be captured)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)