# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"A(?:(?![A-Z]{2}).)*?(\d+)"
test_str = ("A bcd 1 should match and capture 1\n"
"Abcd1 should match and capture 1\n\n"
"A bcd\n"
"A BCd 1\n"
"A bcd 1 EF\n\n"
"must start with an A\n"
"followed by any count of anything unless it's two consecutive upper case letter\n"
"followed by a number (which should be captured)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.