# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(genNode\()\[(\d+(?:,\d+)*)\](?=\))/\1\2/gm;t' <<< "assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), 'Example 2'
"