const regex = new RegExp('(genNode\\()\\[(\\d+(?:,\\d+)*)\\](?=\\))', 'gm')
const str = `assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), 'Example 2'
`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);