using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(genNode\()\[(\d+(?:,\d+)*)\](?=\))";
string substitution = @"\1\2";
string input = @"assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), 'Example 2'
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}