use strict;
my $str = 'assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), \'Example 2\'
';
my $regex = qr/(genNode\()\[(\d+(?:,\d+)*)\](?=\))/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";