re = /(genNode\()\[(\d+(?:,\d+)*)\](?=\))/m
str = 'assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), \'Example 2\'
'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result