import re
regex = re.compile(r"(genNode\()\[(\d+(?:,\d+)*)\](?=\))", flags=re.MULTILINE)
test_str = ("assert Solution().oddEvenList(genNode([2,1,3,5,6,4,7])) == genNode([2,3,6,7,1,5,4]), 'Example 2'\n")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)