const regex = /\burl\((?<url>[^()]+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\burl\\((?<url>[^()]+)\\)', 'gm')
const str = `@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 400;
src: local("JetBrainsMono-Regular"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");
}
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 700;
src: local("JetBrainsMono-Bold"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}