use strict;
my $str = '@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 400;
src: local("JetBrainsMono-Regular"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");
}
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 700;
src: local("JetBrainsMono-Bold"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");
}
';
my $regex = qr/\burl\((?<url>[^()]+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}