import re
regex = re.compile(r"\burl\((?<url>[^()]+)\)", flags=re.MULTILINE)
test_str = ("@font-face {\n"
" font-family: \"JetBrains Mono\";\n"
" font-style: normal;\n"
" font-weight: 400;\n"
" src: local(\"JetBrainsMono-Regular\"),\n"
" url(JetBrainsMono/JetBrainsMono-Regular.ttf) format(\"truetype\");\n"
"}\n"
"@font-face {\n"
" font-family: \"JetBrains Mono\";\n"
" font-style: normal;\n"
" font-weight: 700;\n"
" src: local(\"JetBrainsMono-Bold\"),\n"
" url(JetBrainsMono/JetBrainsMono-Bold.ttf) format(\"truetype\");\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")