re = /\burl\((?<url>[^()]+)\)/m
str = '@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 400;
src: local("JetBrainsMono-Regular"),
url(JetBrainsMono/JetBrainsMono-Regular.ttf) format("truetype");
}
@font-face {
font-family: "JetBrains Mono";
font-style: normal;
font-weight: 700;
src: local("JetBrainsMono-Bold"),
url(JetBrainsMono/JetBrainsMono-Bold.ttf) format("truetype");
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end