using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Identifier: ([^\s]*) Device Name: \[([^\]]*)\] Username: \[([^\]]*)\] Department: \[([^\]]*)\]";
string input = @"Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}