re = /Identifier: ([^\s]*) Device Name: \[([^\]]*)\] Username: \[([^\]]*)\] Department: \[([^\]]*)\]/m
str = 'Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end