// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Identifier: ([^\s]*) Device Name: \[([^\]]*)\] Username: \[([^\]]*)\] Department: \[([^\]]*)\]").unwrap();
let string = "Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}