const regex = new RegExp('Identifier: ([^\\s]*) Device Name: \\[([^\\]]*)\\] Username: \\[([^\\]]*)\\] Department: \\[([^\\]]*)\\]', 'gm')
const str = `Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}