$re = '`Identifier: ([^\s]*) Device Name: \[([^\]]*)\] Username: \[([^\]]*)\] Department: \[([^\]]*)\]`m';
$str = 'Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);