package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Identifier: ([^\s]*) Device Name: \[([^\]]*)\] Username: \[([^\]]*)\] Department: \[([^\]]*)\]`)
var str = `Identifier: 6abca32a Device Name: [devicenamehere] Username: [test@test.com] Department: []`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}