#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d+(?:\s*x\s*\d+)*\s*cm\b"
Local $sString = "Extending Garden Table 100 x 200 x 300 cm white" & @CRLF & _
"Extending Garden Table 200 x 200 cm black" & @CRLF & _
"Extending Garden Table 200 cm black Large"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")