import re
regex = re.compile(r"\b\d+(?:\s*x\s*\d+)*\s*cm\b", flags=re.MULTILINE)
test_str = ("Extending Garden Table 100 x 200 x 300 cm white\n"
"Extending Garden Table 200 x 200 cm black\n"
"Extending Garden Table 200 cm black Large")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")