re = /\b\d+(?:\s*x\s*\d+)*\s*cm\b/m
str = 'Extending Garden Table 100 x 200 x 300 cm white
Extending Garden Table 200 x 200 cm black
Extending Garden Table 200 cm black Large'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end