const regex = /\b\d+(?:\s*x\s*\d+)*\s*cm\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+(?:\\s*x\\s*\\d+)*\\s*cm\\b', 'gm')
const str = `Extending Garden Table 100 x 200 x 300 cm white
Extending Garden Table 200 x 200 cm black
Extending Garden Table 200 cm black Large`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}