package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+(?:\s*x\s*\d+)*\s*cm\b`)
var str = `Extending Garden Table 100 x 200 x 300 cm white
Extending Garden Table 200 x 200 cm black
Extending Garden Table 200 cm black Large`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}