import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+(?:\\s*x\\s*\\d+)*\\s*cm\\b";
final String string = "Extending Garden Table 100 x 200 x 300 cm white\n"
+ "Extending Garden Table 200 x 200 cm black\n"
+ "Extending Garden Table 200 cm black Large";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}