import re
regex = re.compile(r".+?(abcd|Eqhab|guo=98)\1.+", flags=re.MULTILINE)
test_str = ("abcdabcdabcdabcdabcdabcdabcdabcd\n"
"EqhabEqhabEqhabEqhabEqhab\n"
"o98guo=98guo=98guo=98guo=98guo=98guo=98guo98")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)