re = /.+?(abcd|Eqhab|guo=98)\1.+/m
str = 'abcdabcdabcdabcdabcdabcdabcdabcd
EqhabEqhabEqhabEqhabEqhab
o98guo=98guo=98guo=98guo=98guo=98guo=98guo98'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result