#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*"key1"\s*:)(?=.*"key2"\s*:)(?=.*"key3"\s*:).*$"
Local $sString = "{ "key1": "some id", "key2": "some id", "key3": "some id", "key4": "irrelevant" }" & @CRLF & _
"{ "key1": "some id", "key2": "some id", "key5": "some id", "key4": "irrelevant" }" & @CRLF & _
"{ "key1": "some id", "key2": "some id", "key5": "some id", "key3": "irrelevant" }" & @CRLF & _
"{ "key1" : "some id", "key2" : "some id", "key5": "some id", "key3" : "irrelevant" }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")