re = /^(?=.*"key1"\s*:)(?=.*"key2"\s*:)(?=.*"key3"\s*:).*$/m
str = '{ "key1": "some id", "key2": "some id", "key3": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key3": "irrelevant" }
{ "key1" : "some id", "key2" : "some id", "key5": "some id", "key3" : "irrelevant" }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end