const regex = new RegExp('^(?=.*"key1"\\s*:)(?=.*"key2"\\s*:)(?=.*"key3"\\s*:).*$', 'gm')
const str = `{ "key1": "some id", "key2": "some id", "key3": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key3": "irrelevant" }
{ "key1" : "some id", "key2" : "some id", "key5": "some id", "key3" : "irrelevant" }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}