use strict;
my $str = '{ "key1": "some id", "key2": "some id", "key3": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key4": "irrelevant" }
{ "key1": "some id", "key2": "some id", "key5": "some id", "key3": "irrelevant" }
{ "key1" : "some id", "key2" : "some id", "key5": "some id", "key3" : "irrelevant" }';
my $regex = qr/^(?=.*"key1"\s*:)(?=.*"key2"\s*:)(?=.*"key3"\s*:).*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}