import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*\"key1\"\\s*:)(?=.*\"key2\"\\s*:)(?=.*\"key3\"\\s*:).*$";
final String string = "{ \"key1\": \"some id\", \"key2\": \"some id\", \"key3\": \"some id\", \"key4\": \"irrelevant\" }\n"
+ "{ \"key1\": \"some id\", \"key2\": \"some id\", \"key5\": \"some id\", \"key4\": \"irrelevant\" }\n"
+ "{ \"key1\": \"some id\", \"key2\": \"some id\", \"key5\": \"some id\", \"key3\": \"irrelevant\" }\n"
+ "{ \"key1\" : \"some id\", \"key2\" : \"some id\", \"key5\": \"some id\", \"key3\" : \"irrelevant\" }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}