using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*""key1""\s*:)(?=.*""key2""\s*:)(?=.*""key3""\s*:).*$";
string input = @"{ ""key1"": ""some id"", ""key2"": ""some id"", ""key3"": ""some id"", ""key4"": ""irrelevant"" }
{ ""key1"": ""some id"", ""key2"": ""some id"", ""key5"": ""some id"", ""key4"": ""irrelevant"" }
{ ""key1"": ""some id"", ""key2"": ""some id"", ""key5"": ""some id"", ""key3"": ""irrelevant"" }
{ ""key1"" : ""some id"", ""key2"" : ""some id"", ""key5"": ""some id"", ""key3"" : ""irrelevant"" }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}