#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\s)\d{2}([a-zA-Z]+)"
Local $sString = "01FT108 - TMPRD OIL FLOW E944A" - FT" & @CRLF & _
"01FIT110 - FLUSH FROM E101 SHELL" - FIT" & @CRLF & _
"01FC111 - CUTTER FR P21/22 FLOW" - FC" & @CRLF & _
"01FC112 - P6A E946 HEADER FLOW " - FC" & @CRLF & _
"01FT113 - TMPRD OIL FLOW E946A" - FT" & @CRLF & _
"5 TAR LINE FLOW- 01FT005 - FT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")