use strict;
my $str = '01FT108 - TMPRD OIL FLOW E944A" - FT
01FIT110 - FLUSH FROM E101 SHELL" - FIT
01FC111 - CUTTER FR P21/22 FLOW" - FC
01FC112 - P6A E946 HEADER FLOW " - FC
01FT113 - TMPRD OIL FLOW E946A" - FT
5 TAR LINE FLOW- 01FT005 - FT';
my $regex = qr/(?:^|\s)\d{2}([a-zA-Z]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}