import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)\\d{2}([a-zA-Z]+)";
final String string = "01FT108 - TMPRD OIL FLOW E944A\" - FT\n"
+ "01FIT110 - FLUSH FROM E101 SHELL\" - FIT\n"
+ "01FC111 - CUTTER FR P21/22 FLOW\" - FC\n"
+ "01FC112 - P6A E946 HEADER FLOW \" - FC\n"
+ "01FT113 - TMPRD OIL FLOW E946A\" - FT\n"
+ "5 TAR LINE FLOW- 01FT005 - FT";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}