re = /(?:^|\s)\d{2}([a-zA-Z]+)/m
str = '01FT108 - TMPRD OIL FLOW E944A" - FT
01FIT110 - FLUSH FROM E101 SHELL" - FIT
01FC111 - CUTTER FR P21/22 FLOW" - FC
01FC112 - P6A E946 HEADER FLOW " - FC
01FT113 - TMPRD OIL FLOW E946A" - FT
5 TAR LINE FLOW- 01FT005 - FT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end