using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|\s)\d{2}([a-zA-Z]+)";
string input = @"01FT108 - TMPRD OIL FLOW E944A"" - FT
01FIT110 - FLUSH FROM E101 SHELL"" - FIT
01FC111 - CUTTER FR P21/22 FLOW"" - FC
01FC112 - P6A E946 HEADER FLOW "" - FC
01FT113 - TMPRD OIL FLOW E946A"" - FT
5 TAR LINE FLOW- 01FT005 - FT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}