const regex = /(?:^|\s)\d{2}([a-zA-Z]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)\\d{2}([a-zA-Z]+)', 'gm')
const str = `01FT108 - TMPRD OIL FLOW E944A" - FT
01FIT110 - FLUSH FROM E101 SHELL" - FIT
01FC111 - CUTTER FR P21/22 FLOW" - FC
01FC112 - P6A E946 HEADER FLOW " - FC
01FT113 - TMPRD OIL FLOW E946A" - FT
5 TAR LINE FLOW- 01FT005 - FT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}