#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{3})(\d{1,3})?(\d{1,3})?(\d{1,2})?$"
Local $sString = "011" & @CRLF & _
"0112" & @CRLF & _
"01121" & @CRLF & _
"011212" & @CRLF & _
"01121212" & @CRLF & _
"0112121234" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")